Opera for Mac FAQ

The Opera browser was begun by Telenor, the leading Norwegian telecom company, in early 1994. In 1995, Opera was split off into a separate company, Opera Software SA, which remained in Norwegian hands until mid-2016, when the entire Opera browser business was purchased by a Chinese consortium for $600 million, leaving the parent company with Opera Apps & Games and Opera TV.

Opera 1.0 was an in-house project to demonstrate that Telenor’s programmers were capable of creating a compliant browser. The project began in April 1994 with version 1.0 completed in April 1995. Opera developed its own engine to render web pages.

Opera 2.0 was finalized one year later, in April 1996, and the software was released as shareware, but it wasn’t until version 2.1 that Opera was officially released. This version introduced full page scaling, allowing the user to zoom from 20% to 1000%. It was the first version available for Macs.

Opera 3.0 was released in December 1997 and was the first version with JavaScript.

Opera 3.5 used the Elektra rendering engine and added Java support via plug-in. It was the first version to support Cascading Style Sheets (CSS). Version 3.6 (May 1999) improved CSS, HTML, and JavaScript, along with faster rendering of JPEG and GIF images. Version 3.6 was the last to support 16-bit Windows 3.x. A beta known as Opera 3.65 was developed for BeOS and released on July 29, 1999.

Opera 4.0 was the first to require Windows 95 or newer when it was released in June 2000. It gained tabbed browsing and had support for both XML and Dynamic HTML. With version 4.0, Opera began using a cross-platform core.

Opera 5, released at the end of 2000, was ad-supported instead of being shareware with a free trial period. Mac requirements are System 7.5.3 through 9.2.x (there is no native Mac OS X support, but it will run in Classic Mode with OS X 10.4.11 and earlier). The installer notes that Unicode and Full Screen View are not supported. Version 5.1 added mouse gestures in April 2001.

With version 6 in November 2001, Opera gained Unicode capabilities as well as PNG alpha-channel transparency. Mac requirements include a PowerPC Mac and Mac OS 8.6 through OS X 10.2.2 Jaguar – the first Opera release for Mac OS X. Version 6.1 was the first Opera version available for FreeBSD.

With Opera 7.0, the browser moved to the Presto rendering engine in January 2003. Opera 7.0 was the first version to require Mac OS X, dropping support for the Classic Mac OS. Version 7.3 introduced voice capabilities. Version 7.5 added support for RSS news readers.

Opera 8.0 (April 2005) added Scalable Vector Graphics (SVG) support, and version 8.5 dropped ads as Opera became a truly free browser.

Opera for MacOpera 9 (June 2006) gained widgets and was the first to pass the Acid2 test, 9.1 added fraud protection, and 9.2 got Speed Dial, a launch page with thumbnails.

In September 2009, version 10 arrived with speed optimizations and web font support, and 10.5 had an improved JavaScript engine. Opera 10.6 was about 50% faster and is the last version to support PowerPC Macs.

With version 11.0 (December 2010), Opera required an Intel-based Mac, and Opera 12.0 (June 2012) no longer supports OS X 10.4 Tiger.

From there, Opera skipped 13 and 14, going right to version 15 in July 2013, moving from Opera’s Presto layout engine to WebKit, which Apple uses as Safari’s layout engine and Google uses for its Chrome browser, and becoming part of the Chromium project.

Opera moved to an accelerated release schedule, as Chrome and Firefox had already done, and also released versions 16, 17, 18, and 19 in 2013. Opera 20-26 came out in 2014, all based on Chromium. Opera had eight releases in 2015, versions 27 through 34, and through August 2016, it has released Opera 35 through 39.

Overview of System Requirements

It’s very difficult to find system requirements for older versions of Opera. The following is based on what we have running on Mac at Low End Mac headquarters. Updates are appreciated!

  • Opera 6 requires a PowerPC and Mac OS 8.6. OS X 10.2.2 is supported.
  • Opera 10.63 is the last PowerPC version and requires OS X 10.4 Tiger or newer
  • Opera 11 and later require an Intel-based Mac, appears to support OS X 10.4 Tiger
  • Opera 12 requires OS X 10.5 Leopard or newer on an Intel Mac
  • Opera 18 requires OS X 10.6 Snow Leopard or newer
  • Opera 38 recommends OS X 10.9 Mavericks or newer

Further Reading

Keywords: #opera #operabrowser

Short link: http://goo.gl/FhMSOo

searchword: operabrowser