OS X 10.6 Snow Leopard Is Still Good Enough for Me

Honestly, if they didn’t keep dropping support for OS X 10.6 Snow Leopard in new versions of Chrome, Firefox, and Flash, I’d have almost no reason to have OS X 10.9 Mavericks on my Late 2008 13″ Aluminum MacBook (that’s a 2013 OS on a 2008 computer). But my Mid 2007 Mac mini is limited to OS X 10.7 Lion (a 2011 OS on a 2007 Mac), so I’m sometimes left behind by new versions of software.

Launchpad, introduced with OS X 10.7 Lion

With OS X 10.7 Lion, Apple began adding iOS-like features to the Mac, such as the Launcher (above) and “natural” scrolling.

Sticking with Snow Leopard

Point of fact, I am running OS X 10.6 Snow Leopard on that Mac mini (2.0 GHz, 3 GB RAM, Samsung 850 EVO SSD). It’s an OS that came out in 2009. It was the last version of OS X not to roll in iOS-like features like the Launcher (above) and unnatural scrolling. (Don’t get me started!)

Snow Leopard is less demanding of resources and will even run nicely on those first-generation Intel Macs with Core Duo processors and a 2 GB memory ceiling. Best of all, for an old timer like me who has been using AppleWorks since it arrived as ClarisWorks 1.0 for System 7 on my Mac Plus way back in 1991, Snow Leopard is the last version of OS X to run AppleWorks, giving me access to 15 years worth of documents.

Moving forward, I am transitioning to LibreOffice, a freeware office suite that seems to do everything Microsoft Office does (at least everything I need) – and it imports AppleWorks 6 word processing documents. It may also open AppleWorks spreadsheets, drawings, and paintings, although I haven’t yet tried that. (Prior to LibreOffice 4.3, you had to export AppleWorks spreadsheets to Microsoft Excel format and then import that into LibreOffice – which is what I’ve already done with most of my spreadsheets.)

With the exception of iTunes not supporting iPhones and iPads running iOS 9 and later and the version of Safari with Snow Leopard being so old that some sites will complain that it is an unsupported browsers, none of the other “left behind” issues matter much. For browsers, Firefox is current (the last version for OS X 10.8 and earlier), Chrome is barely not current (with the same limitations – the latest version already requires OS X 10.9 or later), and Opera still supports Snow Leopard.

Left Behind By…

Here’s a list of software I use that’s left behind Snow Leopard users and the last compatible versions:

  • Firefox 47.0 (2016) is current, but it is the last version to support OS X 10.6
  • Google Chrome browser 49.0.2623.111 (2016)
  • MacTracker 7.4.1 (2014), but all the data is freely available online
  • LibreOffice 4.3.7.2 (2014)
  • iTunes 11.4 (18) (2014), does not support iOS 9 or later
  • Safari 5.1.10 (2013), the first browser to drop OS X 10.6 support
  • Kindle 1.9.71 (2015) and earlier will launch but cannot register with Amazon’s servers.

Still Being Developed for Snow Leopard

  • Adobe Flash Player 22.0.0.192
  • Opera 25.0.1614.71

Future Uncertain

  • OmniWeb 5.11.2 (no updates since 2012, but version 6.0 was in development last August with OS X 10.10 Yosemite support)

Overall, having a very modern browser that’s not longer being updated – whether Firefox or Chrome – keeps Snow Leopard a useful platform for years to come.

I’m productive with OS X 10.6 daily, and if you’re looking for a bargain in Mac computing, those 2006-2007 machines can run it with 1 GB of memory, run it nicely with 2 GB, and run it quite well with 3 GB of more.

Keywords: #osxsnowleopard #goodenoughforme

Short link:

searchword: goodenoughforme

This site uses Akismet to reduce spam. Learn how your comment data is processed.