10 Forward

OS X and the iMac 266

After solving some significant install problems, OS X runs very nicely.

- 2001.11.30

I had tried the OS X Preview on my Rev C iMac 266 and was less than overwhelmed. It was as cute as a Steve Jobs keynote demonstration, but too unlike anything that this Mac user was used to for me to feel comfortable, and too many of the changes simply seemed change for change's sake - the blue Apple icon in the middle of the menu bar which did nothing, for example.

Still, I was willing to try again with the release version. Still, when the installer greyed out my hard drive, I hesitated. The reason was quickly discovered - my hard drive was formatted with the older HFS file system, rather than the new HFS+ system, a quick peek into the System Profiler verified. Who knew?

Of course, changing that meant reinitializing the drive and starting over with a clean install of OS 9.1. That took some thought. After a few days, however, I bit the bullet. That's when the real fun began!

I booted to the OS 9.1 CD, ran Drive Setup, and initialized the disk. Then I installed OS 9.1 and my most vital applications. Then I installed OS X. Everything seemed fine - I had been able to set up the 9.1 system the way I liked, and I was able to start playing with and customizing X. At the end of the day, I shut down.

In the morning, when I restarted, the bootup got as far as the icon of a disk with a question mark - while the computer made the sounds of a hard drive crash: ka-chunk, ka-chunk, ka-chunk. Definitely not good. I didn't want to say that OS X had eaten my hard drive; it could just be a coincidence.

So I took the computer to my local Mac dealer; they agreed that it sounded like a crashed drive, and convinced me to purchase a new 30 GB drive to replace the iMac's original 6 GB model. They installed it; I took it home and started over.

The OS X CD has a ReadMe file - it suggested that if installing on (among other models), a Rev A through D iMac, "and the hard disk is larger than 8 GB with more than one partition, be sure to select a destination partition for Mac OS X that is completely within the first 8 GB of the disk".

I did read that, and thought, "Okay, so if I leave it with a single partition, I shouldn't have a problem." I repeated all the steps: Install OS 9.1, start up and set up, install applications, install OS X. Restart. Same problem as previous - again, the '?' icon at bootup, again, the repeated ka-chunks.

Too much of a coincidence to think of two drive crashes in a row, but my vendor confirmed that if that was the case, they would replace the drive. He suggested that I try to boot to the 9.1 CD and reinitialize the drive. That worked. (Why didn't they suggest that with my original 6 GB drive and save me the cost of a new drive with more space than I needed? In fact, I later discovered that the original drive would work after being initialized.)

This time I partitioned the drive, making a slightly smaller than 8 GB first partition, with everything else as the second partition. As the ReadMe suggested, I installed OS X into the first partition, along with OS 9.1 - and the same problems repeated themselves.

This time I phoned Apple. After a pleasantly short time on hold, I got a support technician who agreed that the ReadMe file was too vague. She said that on older systems at Apple, they were installing OS 9.1 onto the second partition and OS X onto the first (less than 8 GB) partition. It seems that on those systems, the boot process was confused at finding both operating systems in the same partition, resulting in the inability to start up.

I followed their advice, and everything worked as advertised.

Thanks, Apple, for offering clear instructions in the ReadMe - not! It probably would have worked on my original (6 GB) drive if I had partitioned the drive and installed the two operating systems into a different partition than OS X.

Postscript: When the OS X 10.1 update was released, it required installing OS 9.2.1. That version somehow installed itself into the first partition (where OS X resided). The system booted anyway. So it seems like whatever the problem was with my older system, OS 9.1 and the original OS X, it was fixed in the update.

As always with computers, your mileage may vary.

is a Vancouver (BC, Canada) computer-using elementary school teacher and technology journalist. He publishes two regular columns in Business in Vancouver, a local newsweekly. These and his other writing are available on his website <www.zisman.ca>.

About LEM Support Usage Privacy Contact

Custom Search

Follow Low End Mac on Twitter
Join Low End Mac on Facebook

Favorite Sites

MacSurfer
Cult of Mac
Shrine of Apple
MacInTouch
MyAppleMenu
InfoMac
The Mac Observer
Accelerate Your Mac
RetroMacCast
The Vintage Mac Museum
Deal Brothers
DealMac
Mac2Sell
Mac Driver Museum
JAG's House
System 6 Heaven
System 7 Today
the pickle's Low-End Mac FAQ

Affiliates

Amazon.com
The iTunes Store
PC Connection Express
Macgo Blu-ray Player
Parallels Desktop for Mac
eBay

Low End Mac's Amazon.com store

Advertise

Open Link